K8s does not create calico pods after apply -f

good day.
I’m trying to use calico for our k8s cluster, the cluster is created from scratch, it doesn’t have internet access.
after the following steps:

  1. download and tags docker images:
    calico/node latest 50b52cdadbcf
    calico/pod2daemon-flexvol v3.18.0 2a22066e9588
    calico/node v3.18.0 5a7c4970fbc2
    calico/cni v3.18.0 727de170e4ce
    calico/kube-controllers v3.18.0 9a154323fbf7
  2. download *.yaml files:
  3. followed the instructions: Quickstart for Calico on Kubernetes

the output of kubectl get-A pod-o wide:


please tell me - maybe I missed something?

For air-gapped scenarios you might want to consider Calico Enterprise, we have documentation explaining how to do it on the Enterprise side.

Can you check the logs from the tigera-operator pod please?

thank you, it helped

thank you, the above suggested the correct option - use calico.yaml for on-premises deployments

For any that want to use the operator installation you’d need to set the registry field in the Installation resource to use a different registry.